Test jQuery Updates

Description

Test jQuery Updates is an official plugin by the WordPress team that is intended for testing of different versions of jQuery and jQuery UI before updating them in WordPress. It is not intended for use in production.

It includes jQuery 3.5.1, jQuery Migrate 3.3.0, and jQuery UI 1.12.1. jQuery UI has been re-built for full backwards compatibility with WordPress.

To test:

  1. Use the current version of jQuery in WordPress but disable jQuery Migrate.
  2. Latest jQuery, currently 3.5.1, with the latest jQuery Migrate.
  3. Latest jQuery with the latest jQuery Migrate and latest jQuery UI.
  4. As above without jQuery Migrate.

If you find a bug in a jQuery related script please report it. Instructions are available at the plugin’s settings page.

Default settings

When activated this plugin will not replace the current jQuery but will disable jQuery Migrate. For more information about jQuery Migrate please visit: https://github.com/jquery/jquery-migrate/.

Reviews

2020年11月8日
Thanks! Settings that worked for me is jQuery Migrate to Eable, jQuery version to 3.5.1 , jQuery UI version to 1.12.1
阅读所有的3评价

Contributors & Developers

“Test jQuery Updates” 是开源软件。 以下人员对此插件做出了贡献。

Contributors

“Test jQuery Updates” 已翻译成11 语言环境。 感谢译者的贡献。

将“Test jQuery Updates”翻译成您的语言。

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

更新日志

1.0.1

Update for compatibility with WordPress 5.5-beta1 and newer, allows re-enabling of jQuery Migrate 1.4.1.

1.0.0

Initial release.